Exotel Status Board
Home
Dashboard
BETA
9th June 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [09/06/20 10:58 PM] with 'Major Outage'
Issue has been resolved at [09/06/20 11:08 PM]