BETA

23rd June 2017

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [23/06/17 03:30 PM] with 'Major Outage'

Issue has been resolved at [23/06/17 03:50 PM]