BETA

23rd June 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [23/06/17 03:30 PM] with 'Partial Outage'

Issue has been resolved at [23/06/17 03:51 PM]