BETA

30th May 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [30/05/20 02:28 AM] with 'Partial Outage'

Issue has been resolved at [30/05/20 02:30 AM]