BETA

23rd June 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [23/06/17 12:47 AM] with 'Partial Outage'

Issue has been resolved at [23/06/17 12:48 AM]