BETA

24th May 2020

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [24/05/20 06:38 PM] with 'Partial Outage'

Issue has been resolved at [28/05/20 07:00 PM]