BETA

18th June 2017

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [18/06/17 05:14 AM] with 'Partial Outage'

Issue has been resolved at [18/06/17 05:18 AM]