BETA

16th June 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/06/17 12:29 PM] with 'Partial Outage'

Issue has been resolved at [16/06/17 02:53 PM]