BETA

16th June 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [16/06/17 11:27 AM] with 'Partial Outage'

Issue has been resolved at [16/06/17 03:01 PM]