BETA

16th June 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [16/06/17 11:03 AM] with 'Partial Outage'

Issue has been resolved at [16/06/17 11:23 AM]