BETA

21st May 2020

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [21/05/20 11:38 PM] with 'Partial Outage'

Issue has been resolved at [22/05/20 12:08 AM]