BETA

4th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [04/08/16 01:44 AM] with 'Partial Outage'

Issue has been resolved at [04/08/16 01:50 AM]