Exotel Status Board
Home
Dashboard
BETA
21st May 2020
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [21/05/20 11:58 AM] with 'Major Outage'
Issue has been resolved at [21/05/20 12:18 PM]