BETA

20th May 2020

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [20/05/20 07:28 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [21/05/20 11:28 PM]