Exotel Status Board
Home
Dashboard
BETA
13th May 2020
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [13/05/20 11:48 PM] with 'Major Outage'
Issue has been resolved at [14/05/20 12:18 AM]