BETA

14th June 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [14/06/17 01:52 PM] with 'Major Outage'

Issue has been resolved at [14/06/17 01:53 PM]