BETA

14th June 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [14/06/17 01:51 PM] with 'Partial Outage'

Issue has been resolved at [14/06/17 01:53 PM]