Exotel Status Board
Home
Dashboard
BETA
5th May 2020
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [05/05/20 11:57 AM] with 'Major Outage'
Issue has been resolved at [05/05/20 01:08 PM]