Exotel Status Board
Home
Dashboard
BETA
4th May 2020
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [04/05/20 02:17 PM] with 'Major Outage'
Issue has been resolved at [04/05/20 04:57 PM]