Exotel Status Board
Home
Dashboard
BETA
2nd May 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [02/05/20 02:28 PM] with 'Major Outage'
Issue has been resolved at [02/05/20 02:38 PM]