BETA

13th June 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/06/17 07:16 PM] with 'Major Outage'

Issue has been resolved at [13/06/17 07:17 PM]