BETA

3rd August 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/08/16 05:07 PM] with 'Partial Outage'

Issue has been resolved at [03/08/16 05:09 PM]