Exotel Status Board
Home
Dashboard
BETA
18th April 2020
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
Identified at [18/04/20 10:42 PM] with 'Major Outage'
Issue has been resolved at [18/04/20 11:32 PM]