Exotel Status Board
Home
Dashboard
BETA
17th April 2020
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
5 years ago
Identified at [17/04/20 05:12 PM] with 'Major Outage'
Issue has been resolved at [17/04/20 05:25 PM]