Exotel Status Board
Home
Dashboard
BETA
11th April 2020
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [11/04/20 04:52 PM] with 'Major Outage'
Issue has been resolved at [11/04/20 05:02 PM]