Exotel Status Board
Home
Dashboard
BETA
2nd April 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [02/04/20 01:58 AM] with 'Major Outage'
Issue has been resolved at [02/04/20 02:00 AM]