Exotel Status Board
Home
Dashboard
BETA
1st April 2020
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [01/04/20 03:17 PM] with 'Major Outage'
Issue has been resolved at [01/04/20 03:20 PM]