BETA

1st April 2020

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region
5 years ago

Identified at [01/04/20 02:00 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [01/04/20 02:30 AM]