BETA

16th March 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [16/03/19 08:47 PM] with 'Partial Outage'

Issue has been resolved at [16/03/19 08:48 PM]