Exotel Status Board
Home
Dashboard
BETA
14th March 2020
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [14/03/20 04:49 PM] with 'Major Outage'
Issue has been resolved at [14/03/20 04:50 PM]