Exotel Status Board
Home
Dashboard
BETA
28th February 2020
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [28/02/20 01:20 PM] with 'Major Outage'
Issue has been resolved at [28/02/20 01:30 PM]