Exotel Status Board
Home
Dashboard
BETA
27th February 2020
Chennai
Issue observed for 'Outgoing Calls' in Chennai Region
Identified at [27/02/20 07:00 AM] with 'Major Outage'
Issue has been resolved at [27/02/20 07:40 AM]