BETA

13th June 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [13/06/17 02:58 PM] with 'Major Outage'

Issue has been resolved at [13/06/17 02:59 PM]