BETA

31st July 2016

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [31/07/16 12:07 AM] with 'Partial Outage'

Issue has been resolved at [31/07/16 12:19 AM]