Exotel Status Board
Home
Dashboard
BETA
26th February 2020
Gujarat
Issue observed for 'Outgoing Calls' in Gujarat Region
Identified at [26/02/20 11:40 AM] with 'Major Outage'
Issue has been resolved at [26/02/20 11:50 AM]