Exotel Status Board
Home
Dashboard
BETA
18th February 2020
Gujarat
Issue observed for 'Outgoing Calls' in Gujarat Region
Identified at [18/02/20 11:50 AM] with 'Major Outage'
Issue has been resolved at [18/02/20 12:00 PM]