BETA

11th February 2020

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/02/20 12:00 PM] with 'Major Outage'

Issue has been resolved at [11/02/20 02:00 PM]