Exotel Status Board
Home
Dashboard
BETA
8th February 2020
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [08/02/20 02:20 PM] with 'Major Outage'
Issue has been resolved at [08/02/20 02:30 PM]