Exotel Status Board
Home
Dashboard
BETA
7th February 2020
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [07/02/20 08:20 PM] with 'Major Outage'
Issue has been resolved at [07/02/20 08:30 PM]