BETA

13th June 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [13/06/17 12:05 AM] with 'Partial Outage'

Issue has been resolved at [13/06/17 12:13 AM]