Exotel Status Board
Home
Dashboard
BETA
6th February 2020
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [06/02/20 10:54 AM] with 'Major Outage'
Issue has been resolved at [06/02/20 11:04 AM]