Exotel Status Board
Home
Dashboard
BETA
5th February 2020
Indonesia
Issue observed for 'Outgoing Calls' in Indonesia
Identified at [05/02/20 01:00 AM] with 'Major Outage'