BETA

8th June 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [08/06/17 12:07 PM] with 'Partial Outage'

Issue has been resolved at [08/06/17 12:09 PM]