BETA

28th January 2020

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [28/01/20 12:59 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [28/01/20 01:19 AM]