BETA

8th June 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [08/06/17 12:04 PM] with 'Partial Outage'

Issue has been resolved at [08/06/17 12:12 PM]