BETA

27th January 2020

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [27/01/20 01:09 PM] with 'Partial Outage'

Issue has been resolved at [27/01/20 01:39 PM]