BETA

25th January 2020

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [25/01/20 12:49 PM] with 'Partial Outage'

Issue has been resolved at [25/01/20 12:50 PM]