BETA

24th January 2020

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [24/01/20 02:40 PM] with 'Major Outage'

Issue has been resolved at [24/01/20 05:50 PM]