BETA

16th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [16/03/19 08:17 PM] with 'Partial Outage'

Issue has been resolved at [16/03/19 08:18 PM]