BETA

7th June 2017

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [07/06/17 12:04 PM] with 'Partial Outage'

Issue has been resolved at [07/06/17 12:09 PM]